Have you installed it yet?
Published on February 22, 2011 By CarGuy1 In Personal Computing

Well, I installed the public release of SP1 for Windows 7 64 bit today and everything went fine. My system was already up to date and it was a little over an 85mb download.

I think I'll run a few benchmarks to see if it effects performance in any fashion just for the heck of it.

Anyone else updated yet?


Comments (Page 4)
on Feb 23, 2011

Good thing I didn't opt for the whole thing. I'd still be doing it. lol 900mb. wow!

on Feb 23, 2011

I installed sp1 with no problems, other than it being a slow download.  my sytem is still working like a charm.

on Feb 23, 2011

Gotta love Windows Update...now I have 34 optional updates showing available. SP1 unhid all of the optional language packs.

Easy fix...click on the Arabic pack , hold shift and click the Ukrainian pack, right click and hide updates...done.

Good thing I didn't opt for the whole thing. I'd still be doing it. lol 900mb. wow!

With a good net connection, it may have been faster. It took me 15 minutes to download the 64bit CD from their server and another 20 minutes to install the update.

 

on Feb 23, 2011

Unfortunately I'm stuck with what others provide, slow or not so slow. Maybe one day when I get rich and infamous. lol

on Feb 24, 2011

Maybe one day when I get rich and infamous.

You're already infamous, Uvah... with a reputation longer than my arm for being totally kooky.

But you're my kind of people.

on Feb 24, 2011

I are? Wow!

on Feb 24, 2011

I caved in pretty quickly and normally wouldn't mention how I waffled like that but I just had to mention that it took about 20 minutes to download and install.

on Feb 24, 2011

Mine took a total of ninety minutes give or take.

Meta
Views
» 8111
Comments
» 53
Sponsored Links