Have you installed it yet?
Published on February 22, 2011 By CarGuy1 In Personal Computing

Well, I installed the public release of SP1 for Windows 7 64 bit today and everything went fine. My system was already up to date and it was a little over an 85mb download.

I think I'll run a few benchmarks to see if it effects performance in any fashion just for the heck of it.

Anyone else updated yet?


Comments (Page 1)
on Feb 22, 2011

Problem updating to SP1. Twice the update failed. Help.

on Feb 22, 2011

Thanks for the reminder, downloading now

on Feb 22, 2011

Mine says its downloading but now it looks like it is stuck at 19%. I don't know if its downloading or not. Download is very slow. At 21% now. I'll come back when done. Fingers crossed. Toes tongue and eyeballs too. lol

on Feb 22, 2011

The downloading and installation of SP1 went fine for me.  I did notice one thing though, I now have more space available on my HD.  Is that because the update deleted some stuff?

on Feb 22, 2011

I think there's something wrong with mine. Its at 24% and doesn't seem to be doing anything.

on Feb 22, 2011

Uvah, downloading did take a little while for me also, installing went much quicker.

on Feb 22, 2011

Its at 94%. I'm pullin' my hair out over here. I thought my lappy was having a heart attack.lol.

on Feb 22, 2011

I downloaded mine directly from Microsoft since I have more than 1 PC to update.

You can download it directly from here.

 

Be sure to read the file descriptions in the instructions for the correct file to download.

on Feb 22, 2011

The download finished. Its installing now. About three quarters done but its very slow. You know the animation that goes across the progress ber. It stops and starts, like its hanging up instead of going smoothly. I noticed this a few times when I dl stuff. Sometimes the download hangs up. What might cause that?

on Feb 22, 2011

carguy which one do you download?

Win/64 here

on Feb 22, 2011

Download the one for x64 bit.

on Feb 22, 2011

Never mind I believe its this one

 

windows6.1-KB976932-X64.exe

You said it was 85meg. My downlaod is 937 meg. Hope I'm doing the right one.

on Feb 22, 2011

It was actually 903 megs and took 8 minutes.

on Feb 22, 2011

903 megs

Hope I'm doing the right one.

 

You are.....

on Feb 22, 2011

thanks yrag. You are Ok, I don't care what the others say.

Meta
Views
» 5767
Comments
» 53
Sponsored Links